Related Topics


[Video CMS v4]Issues with Upgrade from PHPVibe 3.3/3.4 to PRO 3.5  (Read 3252 times) Print

1 B


marius20foc  March 09, 2014, 04:40:30 PM

when i try to acces up3to5.php i get some warnings :
Code
Warning: Table 'xxxxx.vibe_langs' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Table 'xxxxx.vibe_langs' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Table 'xxxxx.vibe_langs' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Table 'xxxxx.vibe_langs' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Table 'xxxxx.vibe_languages' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Table 'xxxxx.vibe_languages' doesn't exist in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'token' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'tmp_source' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'privacy' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'type' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'sub' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'media' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Unknown column 'order' in 'vibe_homepage' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

Warning: Duplicate column name 'mtype' in /home4/xxxxx/public_html/lib/class.ezsql.php on line 249

I can't be that dumb to be the only one :)

I found something in the forum, from an issue stated in 3.3RC1 to 3.4 update, I have created via phpmyadmin the vibe_langs table but theese warnings won't go away ...

when i run setup somewhere in the verifying stages it states : "The tables already exist! Database was not installed to avoid overwrite."

Logged


marius20foc  March 09, 2014, 05:08:05 PM

sorry, can't edit.


even if installation was not completed apparantely cron.php made some mess.
I've got the following message from my hosting service :
Unfortunately, a script running on your hosting was found to be causing server issues that negatively affected other users. We have been forced to place resource restrictions on your account at this time.

Logged


Alexander  March 09, 2014, 05:11:10 PM

Code
CREATE TABLE IF NOT EXISTS `vibe_langs` (
  `lang_id` bigint(20) unsigned NOT NULL AUTO_INCREMENT,
  `term` longtext NOT NULL,
  PRIMARY KEY (`lang_id`)
) ENGINE=MyISAM  DEFAULT CHARSET=utf8 AUTO_INCREMENT=0 ;

I think I've forgot to do the prefixes on install, do you run other prefix than "vibe_" ?
Mario is gonna kill me  :-\


My bad, to many version here, got confused. Prefixes are fine in the archive.

Logged

marius20foc  March 09, 2014, 05:13:33 PM

no, my DB_PREFIX is  vibe_

Logged


Alexander  March 09, 2014, 05:21:21 PM

Create the table, run the update after.

Logged

marius20foc  March 09, 2014, 05:36:04 PM

from what a brief peek looks like, the website works, its 3.5 now, admin/moderator works...for now no problems with the website itself.

somehow a problem is that running that up3to5.php will still showup the warnings with the duplicates, just those warnings. is it safe ?


also, cron's make a mess, second restriction in 30 mins from hostgator :(

Logged


Alexander  March 09, 2014, 05:41:14 PM

also, cron's make a mess, second restriction in 30 mins from hostgator :(

Shared hosting, many crons, not a good option.

The normal procedure is :

Ask content from youtube, copy content, process content, insert every video with an sql query.

Nothing very easy.

Logged

marius20foc  March 09, 2014, 09:52:01 PM

hmm, I supposed it was the crons...but I never managed to set up any  :o
I had a 5000% spike in CPU usage though when installing ...


Thx for the help..I guess repetition is the mother of knowledge  :D

Logged


Alexander  March 09, 2014, 10:14:39 PM

Hmm, not sure why, any file was the issue? Can you ask support, it would be useful in case it happens again.

Logged

kathir1833  March 09, 2014, 10:15:22 PM

having problem with upgrade 3.4 to 3.5

am getting following errors..

Notice: Constant page already defined in /home/kolly/public_html/vibe_setts.php on line 30
Notice: Constant embedcode already defined in /home/kolly/public_html/vibe_setts.php on line 34
Notice: Constant video already defined in /home/kolly/public_html/vibe_setts.php on line 35
Notice: Constant videos already defined in /home/kolly/public_html/vibe_setts.php on line 36
Notice: Constant channel already defined in /home/kolly/public_html/vibe_setts.php on line 37
Notice: Constant channels already defined in /home/kolly/public_html/vibe_setts.php on line 38
Notice: Constant playlist already defined in /home/kolly/public_html/vibe_setts.php on line 39
Notice: Constant note already defined in /home/kolly/public_html/vibe_setts.php on line 40
Notice: Constant profile already defined in /home/kolly/public_html/vibe_setts.php on line 41
Notice: Constant show already defined in /home/kolly/public_html/vibe_setts.php on line 42
Notice: Constant members already defined in /home/kolly/public_html/vibe_setts.php on line 43
Notice: Constant share already defined in /home/kolly/public_html/vibe_setts.php on line 44
Notice: Constant subscriptions already defined in /home/kolly/public_html/vibe_setts.php on line 48
Notice: Constant manage already defined in /home/kolly/public_html/vibe_setts.php on line 49
Notice: Constant me already defined in /home/kolly/public_html/vibe_setts.php on line 50
Notice: Constant buzz already defined in /home/kolly/public_html/vibe_setts.php on line 51
Notice: Constant mostliked already defined in /home/kolly/public_html/vibe_setts.php on line 53
Notice: Constant mostviewed already defined in /home/kolly/public_html/vibe_setts.php on line 54
Notice: Constant promoted already defined in /home/kolly/public_html/vibe_setts.php on line 55
Notice: Constant browse already defined in /home/kolly/public_html/vibe_setts.php on line 56

Logged


Alexander  March 09, 2014, 10:39:53 PM

Hi, I've closed your ticket, please if you post here do not send mail also.

You clearly have not followed this tutorial, it states clearly that the vibe_config.php it's incompatible and not just keep it. You have double declarations.

And you are missing the pages table, did you upgrade from 3.3 to 3.4? Cause you are missing a feature that 3.4 has http://www.phprevolution.com/forum/development/manually-upgrading-from-phpvibe-3-3-to-phpvibe-3-4/

Logged

marius20foc  March 09, 2014, 10:55:51 PM

Hmm, not sure why, any file was the issue? Can you ask support, it would be useful in case it happens again.

It was up3to5.php's fault...so they said ???

Logged


Alexander  March 09, 2014, 11:05:45 PM

It was up3to5.php's fault...so they said ???

I can't image why it would go wrong, but, my advice is to optimize those database tables, check for errors with phpmyadmin also.

Logged

marius20foc  March 10, 2014, 12:20:50 AM

it gets frustrating  :) I watched a video, shared it, but then a friend said it's returning an error . I actually watched it, then in 20 seconds it went down. entire site.


error log says :
Code
 [Sun Mar 09 15:11:52 2014] [error] [client 180.76.6.46] File does not exist: /home4/xxxxxxx/public_html/video
[Sun Mar 09 15:10:48 2014] [error] [client 79.115.9.154] File does not exist: /home4/xxxxxxx/public_html/video, referer: http://www.vipefun.com/
[Sun Mar 09 15:10:40 2014] [error] [client 220.181.108.76] File does not exist: /home4/xxxxxxx/public_html/video
[Sun Mar 09 15:07:30 2014] [error] [client 79.115.9.154] File does not exist: /home4/xxxxxxx/public_html/video, referer: http://www.vipefun.com/

admin/moderator works just fine, index works fine, everything is good 'till you click something :-[


is the database backward compatible with 3.3RC1? I'm thinking of going back for a while

Logged


marius20foc  March 10, 2014, 02:57:23 AM

deleted everything but cachemedia, rawmedia, uploads and vibe_config.php and restarted the upgrade/install process. Tedious process but it came to senses...

Logged


Alexander  March 10, 2014, 01:48:47 PM

is the database backward compatible with 3.3RC1? I'm thinking of going back for a while

It should work.
But there is no change in .htaccess (except one extra rewrite rule affecting feed) or router.php since 3.3

Logged