Related Topics


[Video CMS v4]how to add video.js player to my default player?  (Read 1039 times) Print

1 B


ollipaust  April 14, 2014, 09:09:49 PM

hi

i would like to use video.js as my default player since the new player rly disappointed me.
is it even possible / compatible?

Logged


ollipaust  April 15, 2014, 07:33:44 PM

Is the video.js player compatible ??? is it possible to do this?? please tell me which files i have to edit and how ..

thanks

Logged


Alexander  April 16, 2014, 01:35:18 PM

We will add that to, coding is almost done, but with the Easter vacation at the door we had to postpone it.

Logged

ollipaust  April 16, 2014, 04:53:33 PM

We will add that to, coding is almost done, but with the Easter vacation at the door we had to postpone it.

okay thats good news!

Logged


fry  September 27, 2014, 03:06:04 AM

is it ready or no videojs   if not pleas tell us how to add it and we will try

Logged


@Mario  September 27, 2014, 03:48:41 PM

is it ready or no videojs   if not pleas tell us how to add it and we will try

Never finished it, didn't like it once hooked, didn't work with hide path, etc.
It can be hooked like any other player in lib/class.providers.php

Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  September 29, 2014, 11:28:43 PM

ok . so i need any jplayer run vast/vpaid tag . or any other player to connect it to phpvibe to work in vast vpaid and also work in html 5 . what your advise as jwplayer and others is chage by cpm and that cost alot as you know so i want tohave our player like easyplayer and jplayer so pleas i need that fast

Logged


@Mario  September 30, 2014, 09:05:57 PM

I don't know anything about vast/vpaid tag, never have used, so I can't advice you.
If you think videojs can do it for you, go with that, but when I've checked their ads plugin it was very poor.




Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  September 30, 2014, 09:18:34 PM

jplayer look great but is it work perroll with vast tag  or xml   .

Logged


fry  September 30, 2014, 10:16:16 PM

as i need to run xml ads in perroll . what your advise to me pleas ? or advise me by anyplayer that work with it and i will buy it

Logged


@Mario  September 30, 2014, 10:59:06 PM

jplayer doesn't have the vast tag or any of that support, just html spots which will render the content you add iframe/js/html/.

jwplayer and flowplayer have paid support for it as I know
http://www.jwplayer.com/video-ads/
https://flowplayer.org/forum/#!/plugins#vast-support-in-flowplayer

As I recall this video ads usually have a very poor CPC.

Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  October 26, 2014, 11:43:18 PM

how to make flowplayer html5 run atuoplay in video starting ? as i change in flowplayer js but it not work , pleas tell me from where and which line

Logged


@Mario  October 27, 2014, 02:30:29 PM

how to make flowplayer html5 run atuoplay in video starting ? as i change in flowplayer js but it not work , pleas tell me from where and which line


http://demos.flowplayer.org/basics/autoplay.html

All player embeds are for now in lib/class.providers.php

Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  October 27, 2014, 06:58:16 PM

ok it is in  lib/class.providers.php  but what code i should change as there is only autostart for jwplayer not Flowplayer , pleas tell me what code i should be change in  lib/class.providers.php ?

Logged


@Mario  October 27, 2014, 07:07:34 PM

The player's embed function has the same name as the player in this case.

Code
public function flowplayer($file,$thumb, $logo = null, $type=null) {
     $embed = ' <link rel="stylesheet" type="text/css"href="' . site_url() . 'lib/players/fplayer/skin/functional.css">';
      $embed .= '
     <script>     var thelogo = "'.$logo.'"; var thelink = "'.site_url().'";</script>
     <script src="' . site_url() . 'lib/players/fplayer/flowplayer.min.js"></script>';
      $embed .= '<div data-swf="' . site_url() . 'lib/players/fplayer//flowplayer.swf"  class="flowplayer color-alt no-background aside-time" data-flashfit="true"  data-scaling="scale" data-embed="false" data-analytics="' . get_option("googletracking") . '">
       <video poster="' . $thumb . '" loop="loop">
       <source type="video/' . str_replace("ogv", "ogg", $type) . '" src="' . $file . '"/>';
      $embed .= '</video>   <>';
     
   return  $embed;                 
     }

Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  October 27, 2014, 08:06:18 PM

Mario i know this the embed code fro fplayer but what i have to change in it to make it work autoplay? , as i tried to add <video autoplay> in the embed code but not work it just run the sound and the video not run , i kow i make it wrong  , could you pleas copy to me the embed code with video autoplay run and i will copy it and past it?
thank you for your help

Logged


fry  October 28, 2014, 01:04:30 AM

pleas gave me the code ready with autoplay , i am witting sir

Logged


fry  October 28, 2014, 01:58:42 PM

any comment pleas?

Logged


fry  October 28, 2014, 07:55:14 PM

my friend
i add this code <video autoplay> above this code <video poster="' . $thumb . '" loop="loop">  and it work but it take more than 1 m to run the video so i think i put the code in wrong place code you show me where i had to put it
best

Logged


@Mario  October 28, 2014, 08:33:33 PM

Changing:

Code
<video poster="' . $thumb . '" loop="loop">

to


Code
<video poster="' . $thumb . '" loop="loop" autoplay>


as per that tutorial, works fine for me.

Logged
Hello!
If you wish to learn how to start coding on the PHPVibe Video CMS head to the blog.

Please use the search before opening a new topic!


fry  October 28, 2014, 08:39:41 PM

thanks , it work great

Logged