Related Topics


[Video CMS v4]Error uploading video and thumbnails  (Read 993 times) Print

1 B


aralom  April 11, 2015, 10:47:35 AM

Hello, everybody.
I been spend a whole day reading, searching about this issue and i have no clue what is happening.
When i try to upload a video sometimes success other video nothing happend, when there is no alerts about the video upload process im sure loading the video was not successful.
I test with firefox, chrome, maxthon, opera, IE, safary all newest versions With PC and mac.

My VPS server have installed: ffmpeg version 2.3.3-
FFmpeg executable and Server bin path are correct, and upload files at 450mb.

Im using fresh installation for PHPVibe 4 - Video CMS
v4 [Stable]; Current subversion is 14 ; Your subversion is 14

Attach some file as a reference.

My problem is: Error uploading video and thumbnails

Any Advice?

Best Regards!

Logged


Alexander  April 15, 2015, 09:54:33 PM

Hi, did you try the ffmpeg with the tester http://www.phpvibe.com/requirements/?
Post here the result so I can check and guide you (switch to ffmpeg test)

Logged

aralom  April 15, 2015, 10:54:38 PM

Hello Alexander, attach some screen capture.

Best Regars

Logged


Alexander  April 15, 2015, 11:14:39 PM

Ok, so the ffmpeg has no output in your test (error, or anything).
Check this http://www.phpvibe.com/forum/discussions/error/msg21097/#msg21097

Logged

aralom  April 16, 2015, 12:09:39 AM

Hello alexander.
I read the post that you advice.


This is new test result.

---------------------------------------

FFMPEG tester
File to convert: test.avi
Converted file: test.mp4
Command send to server: ffmpeg -i test.avi -vcodec libx264 -s 480x320 -threads 4 -movflags faststart test.mp4 2>&1
FFmpeg output

array(18) {
 
  • =>

  string(67) "FFmpeg version 0.6.5, Copyright (c) 2000-2010 the FFmpeg developers"
  [1]=>
  string(73) "  built on Jan 29 2012 17:52:15 with gcc 4.4.5 20110214 (Red Hat 4.4.5-6)"
  [2]=>
  string(747) "  configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --mandir=/usr/share/man --incdir=/usr/include --disable-avisynth --extra-cflags='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -fPIC' --enable-avfilter --enable-avfilter-lavf --enable-libdc1394 --enable-libdirac --enable-libfaac --enable-libfaad --enable-libfaadbin --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libx264 --enable-gpl --enable-nonfree --enable-postproc --enable-pthreads --enable-shared --enable-swscale --enable-vdpau --enable-version3 --enable-x11grab"
  [3]=>
  string(35) "  libavutil     50.15. 1 / 50.15. 1"
  [4]=>
  string(35) "  libavcodec    52.72. 2 / 52.72. 2"
  [5]=>
  string(35) "  libavformat   52.64. 2 / 52.64. 2"
  [6]=>
  string(35) "  libavdevice   52. 2. 0 / 52. 2. 0"
  [7]=>
  string(35) "  libavfilter    1.19. 0 /  1.19. 0"
  [8]=>
  string(35) "  libswscale     0.11. 0 /  0.11. 0"
  [9]=>
  string(35) "  libpostproc   51. 2. 0 / 51. 2. 0"
  [10]=>
  string(45) "[avi @ 0x11bf670]max_analyze_duration reached"
  [11]=>
  string(0) ""
  [12]=>
  string(101) "Seems stream 0 codec frame rate differs from container frame rate: 58.00 (58/1) -> 29.97 (30000/1001)"
  [13]=>
  string(31) "Input #0, avi, from 'test.avi':"
  [14]=>
  string(59) "  Duration: 00:01:09.76, start: 0.000000, bitrate: 675 kb/s"
  [15]=>
  string(107) "    Stream #0.0: Video: h264, yuv420p, 400x230 [PAR 1:1 DAR 40:23], 29.97 fps, 29.97 tbr, 29.97 tbn, 58 tbc"
  [16]=>
  string(64) "    Stream #0.1: Audio: mp3, 44100 Hz, 2 channels, s16, 128 kb/s"
  [17]=>
  string(30) "Unrecognized option 'movflags'"
}
int(1)
‚Äč

Logged


aralom  April 16, 2015, 12:38:08 AM

The current ffmpeg version is 2.3.3 as you can see from the following:
---
root@vps773 [~]# ffmpeg -v
ffmpeg version 2.3.3- newbielink:http://johnvansickle.com/ffmpeg/ [nonactive] Copyright (c) 2000-2014 the FFmpeg developers
built on Sep 2 2014 16:32:53 with gcc 4.8 (Debian 4.8.3-9)
configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --disable-ffserver --enable-libass --enable-gnutls --cc=gcc-4.8
libavutil 52. 92.100 / 52. 92.100
libavcodec 55. 69.100 / 55. 69.100
libavformat 55. 48.100 / 55. 48.100
libavdevice 55. 13.102 / 55. 13.102
libavfilter 4. 11.100 / 4. 11.100
libswscale 2. 6.100 / 2. 6.100
libswresample 0. 19.100 / 0. 19.100
libpostproc 52. 3.100 / 52. 3.100
---

Logged


Alexander  April 16, 2015, 05:15:15 PM

aralom, it seem to me you have 2 ffmpeg installs which conflict, and the old one is used for converting.

Logged

aralom  April 17, 2015, 01:53:10 AM

Ok, what i need to do? ::)
How can i "say" at phpvibe select the right ffmpeg

Regards!

Logged


Alexander  April 17, 2015, 03:21:49 PM

It has no connection with phpvibe, is the server's exec() which selects it.
What I advise you is to remove ffmpeg (both) and reinstall. This would be the 100% safe solution.
It's always a bad idea to have 2 ffmpegs installed.

Logged

aralom  April 18, 2015, 03:08:32 AM

Hello Alexander today contact at Support about FFMPEG versions, the uninstall both version and install just one.
I run the rest again and give this:
-------------------------------
File to convert: test.avi
Converted file: test.mp4
Command send to server: ffmpeg -i test.avi -vcodec libx264 -s 480x320 -threads 4 -movflags faststart test.mp4 2>&1
FFmpeg output

array(53) {
 
  • =>

  string(105) "ffmpeg version 2.6.2-    newbielink:http://johnvansickle.com/ffmpeg/ [nonactive]    Copyright (c) 2000-2015 the FFmpeg developers"
  [1]=>
  string(40) "  built with gcc 4.9.2 (Debian 4.9.2-10)"
  [2]=>
  string(542) "  configuration: --enable-gpl --enable-version3 --disable-shared --disable-debug --enable-runtime-cpudetect --enable-libmp3lame --enable-libx264 --enable-libx265 --enable-libwebp --enable-libspeex --enable-libvorbis --enable-libvpx --enable-libfreetype --enable-fontconfig --enable-libxvid --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-gray --enable-libopenjpeg --enable-libopus --enable-libass --enable-gnutls --enable-libvidstab --enable-libsoxr --cc=gcc-4.9"
  [3]=>
--------------------------------------

When i upload a video using admin account no problem if the video is small (1mb) but if is more or 30mb seems is uploading but nothing happend, im going to check Unpublished / Trash Can but there is Nothing.

I HAVE NO IDEA WHAT IS WRONG, today i made the update at subversion is 15, STILL IS NOT WORKING, i you want i can give you, admin account and FTP.

Regards!

Logged


Alexander  April 20, 2015, 05:31:48 PM

Hi aralom, that's not necessarily.
If the 1mb works, then the problem is not in the code or ffmpeg.
What's your server hardware?
Ffmpeg is really heavy, for example on our setup (3.0 quad with 8 gb of ram) a 1gb movie with the Hd version of the ffmpeg takes about an hour to convert and it spikes the processor to 1000% per small periods on this timeframe .
As for where things may fail: monitor videocron.php's ffmpeg conversion order in your host's processes list, it may be killed for using too many resources.

Logged

aralom  April 21, 2015, 12:00:45 AM

Hello Alexander, just for a moment works the ffmpeg just one video and after this IS NOT WORKING anymore.
Im using VPS server:
-----------------------------
40 GB Space
2000 Gb Traffic
1.8 GHz Ded. CPU
2 CPU Cores
1 GB Ded. RAM
128 MB Burst RAM
------------------------------
Actually i don't have configured any cron process for video.

Any Advice?

Regards

Logged


aralom  April 21, 2015, 01:07:04 AM

Alexander for testing i just disable ffmpeg and try to upload a video -30mb-, looks like will work but there is no luck, same problems.

Regards.

Logged


Alexander  April 22, 2015, 08:28:14 PM

aralom, your server is very small, not fit at all for ffmpeg conversions.
1 gb of ram is low, 1 gb virtual ram is really bad.
this explains why it would stop your operations, the server is overloaded by the ffmpeg.

http://www.phpvibe.com/choosing-a-server-for-phpvibe/

Logged

aralom  April 25, 2015, 06:12:40 AM

Hello Alexander, thank you for your help and support.
What do you think about this server?:

Dedicated Server
------------------------------
E5-2620 V2 6x2.0Ghz
2 x 1 TB Storage
24 GB RAM
10 TB Bandwidth
-----------------------------
Can work without problems?

Best Regards!

Logged


Alexander  April 25, 2015, 04:03:34 PM

For sure, that's a great hardware piece. What's the price for it?

Logged

aralom  April 25, 2015, 10:19:17 PM

$319.00 per month.
newbielink:http://www.tmdhosting.com/dedicated-servers.html [nonactive]

Regards!

Logged


Alexander  April 26, 2015, 06:34:24 PM

Pretty expensive, I got something like the one which is 269$/month at 100$/month from LeaseWeb.com

Logged

aralom  May 04, 2015, 10:25:33 AM

Hello Alexander, im really, really tired i have no idea what is happening, already made all steps:
1) upgrade server:
Dedicated Server
------------------------------
E5-2620 V2 6x2.0Ghz
2 x 1 TB Storage
24 GB RAM
10 TB Bandwidth
-----------------------------

2) upgrade ffmpeg version 2.6.2

This is not working same problem, When i try to upload a video sometimes success other video nothing happens, when there is no alerts about the video upload process im sure loading the video was not successful.

I test with firefox, chrome, maxthon, opera, IE, safary all newest versions With PC and mac.
Attach actual configuration.

Please help me!! :'(

Regards!

Logged


aralom  May 04, 2015, 10:33:03 AM

More pics as reference

Logged


Alexander  May 04, 2015, 09:33:45 PM

Your ffmpeg path in the Settings -> FFMPEG is not the same as the one you use in the tester (from what I see, there is also a weird space there in the PHPVibe's path settings for ffmpeg).

Logged

aralom  May 04, 2015, 10:48:09 PM

Hello Alexander, do you want moderator access and check, because you say where is the possible error but not how to fix it.

Regards

Logged


Alexander  May 05, 2015, 06:30:43 PM

The solution is very simple.

Fffmpeg executable :
In your PHPVibe - /usr/bin/ffmpeg/ (not working)
In your tester - /usr/local/bin/ffmpeg (working)


Logged